Engine Sensors

  Tel No. +612 4987 3775 
Skip Navigation Links.
 

                         

MOST COMMON FAULTS (page 2)

 

VT-VY

Cuts out, hard to start

Faulty wiring in fuel tank, replace fuel pump assembly or if losing spark - coil pack assembly.

VZ ,VE,Rodeo 3.6 v6 mifire codes ie ,cyls 1,,3,5 or other bank 2,4,6 Top of engine sludged up with oil,cam drivers are oil press operated and as oil pressure increases opens and closes ports on drivers to feed oil to convertors on camshafts and this increases and decreases advance ,if ports blocked cannot work,inspect and clean or replace cam drivers,note this is a common fault

VZ-VE V6

Misfire. No fault codes.

Coils misfiring ( Common fault) replace.

VZ- VE V6

Car wont start or runs worse after lifting manifold off

When you lift manifold off to check or replace coils or injectors it damages wiring loom to coils (gets brittle from heat). Replace loom kit to coils.You can get new loom kit from holden approx.$300

VZ-VE V6 Cam sensor codes BEWARE-test cam sensors,try swapping to get rid of code-Timing chain worn and cams are out of sync-replace timing chain kit major job-NOTE this is a common fault
VZ-VE /Rodeo V6

Misfire and or injector code after fitting coil

 

Faulty ECU not firing 1 injector,check with noid light,due to a faulty coil,the 4th wire on coil is a feedback to ECU so when a coil has a problem the ECU turns off injector to that cyl so raw fuel doesnt stuff up CAT-if coil has a short it damages inj driver in ECU.we have pre programed ECUs in stock-note common fault
 VZ-VE 6 code /cyls 1.3.5 or
2.4.6 misfire
 Timing chain streched-or cam driver stuck on due to sludged up oil-read above section
 VE-V6        Fans on all the time  Faulty fan or a/con relay
 VE-SV6 Mass Airflow fault code BEWARE-if you have changed air flow and code keeps coming back check the Variable intake manifold motor at the back of the manifold is jamming up causing this code to keep coming on
Frontera 1998 on Cuts out while driving or no start sometimes Wiring shorts out on metal retaining clip at firewall

Holden Jackaroo 3.2 & 3.5 Petrol

Surging & runs rich

Airflow meter, but usually O2 sensor faulty.

Holden Jackaroo 3.0

Turbo Diesel

Wont start after fitting new clutch assembly

Flywheel is in wrong position for crank sensor. You must mark flywheel first. As it fits on 8 ways

(Common fault).

Holden Jackaroo 3.0

Turbo Diesel 4X1 engine

Runs rough, No power!

If no codes (Dealer only)

BEWARE send to dealer! mainly seals on injectors or injectors blocked or leaking

$14000 for new engine.

Do not do head gasket!

Holden Rodeo V6 3.2

Hard to start

Cranks ok

Replace battery(common fault)

Losing voltage to ECU on start

 Rodeo 2.6

Hard to start - no fuel pressure

Check voltage to pump connector near fuel filter. Also main brown relay under bonnet.

Rodeo 2.2 C22ne runs rough,no start code-41-42-ign high voltage,computer or bad earth wire near alternator behind timing cover near head.this is a common fault

Rodeo 2.6

No spark

Hard to start

Check voltage to coil on crank, check brown relay, also fuse 9 under dash will have bad connection

(common fault)

Rodeo/Jackaroo 3.5

TPS Code constant

Replace TPS, if code keeps coming back, Check 02 sensor switching, If it has a faulty 02 it will bring up TPS code as circuit is part of fuel trim, try disconnecting 02 sensor to get rid of TPS code

Rodeo/ Jackaroo V6

2000 on

Runs rough on one bank after fitting heads or engine

Loom to o2 sensors on wrong bank ie. left hand loom going to right hand oxygen sensor. Wiring loom reads different to both o2 sensors, cuts injection duration to one bank

 Rodeo-late model 2000 on Goes into limp mode when engaging 4WD,blows 10amp ecu fuse Check blue wire in loom above transfer case,rubs through and earths out on case-note-common fault

Holden Viva 05 on

Misfire after fitting head,ECU, or battery disconnected, Check light on   Code-Engine misfire

Computer lost memory for cam timing, Software has to be reprogramed by a tech2 or a G Scan. NOTE - This is a common fault.

Honda

most models to 1999

No fuel pressure or spark

Check 12volts to pump/or dizzy, If no voltage main relay (8 pin plug under dash) Faulty- resolder board or replace(common fault)

 Honda Jazz Surging Faulty EGR valve stuck open
Honda CRV Noise in rear,sound like wheel bearing Noise is from wrong diff oil,Honda has new grade diff oil,common fault

Hyundai - 4cyl / V6 1996 on with Crank angle sensor behind timing belt.

Runs rough. Crank sensor code (Not always). Crank sensor is behind timing belt.

Timing belt out 1 tooth or crank sensor oil soaked or C.A.S disc plate loose behind crank timing belt pulley (common fault).

 Hyn,models with crank sensor behind timing belt  misfire,no codes  check chopper plate behind belt for crank sensor not bent or loose

Accent

High idle-code for idle motor stuck on

check for 12 volts to plug for idle motor,if not there it has a blown fuse under bonnet

Accent High idle after fitting head or engine work TPS and ISC plug connectors on back to front  (they both fit) common fault
 Accent  Running rich,02 codes  Faulty purge control valve-sucking fuel into manifold,take off vacuum hose to manifold and check-common fault

Hyundai Excel

series 1 & 2

Runs rough.

No fault codes.

Faulty computer

Excel series 3/ Accent

Cuts out after 3 seconds from start   

Losing power to coil & injectors. Faulty EFI main relay or faulty ignition switch (worn)

Common fault

Excel Series 3

Cuts out / Hard to start. No fault codes

Faulty crank angle plug connector, replace plug kit & crank sensor.

Excel Series 3

Single cam

Runs rough & rich

Airflow meter on back to front (common fault)

Excel Series 3

Twin cam

Runs rough, surging

Faulty TPS or map sensor,check codes

Hyundai Grandeur V6

Surging, no power

Airflow meter faulty, disconnect to verify.

Hyundai Lantra 1.6 & 1.8 DOHC

Running rough, Bad idle. No Power

Camtiming may appear right, but use straight edge on cam marks. Tensioner not set right.

Jeep 6 cyl

TPS Codes

Check wires not broken at junction of fuel rail for TPS. Test voltages and earth at TPS, Do wiggle test at loom near injector rail                                                                        

Jeep Cherokee  6cyl

 

Vechile starts,runs for a few seconds and then cuts out

 

Body control does not recognise ignition key transponder,to reset,remove 50 AMP enscapulated fuse for 30 seconds,Fuse is located in engine fuse box (MUX/T-TOW) Refit fuse and vechile should start

 

Jeep Cherokee & Wrangler 94-00

Cutting out

Wont start

Crank sensor on flywheel faulty. Replace (common fault).OR Auto shut down relay faulty,if no power to coil,disconnect crank sensor,if power appears cas faulty

Jeep V6/V8 Crank sensor code We have found that vechile still cuts out and this code is still there after fitting crank sensor,but if you change CAM sensor as well it fixes problem,Crank sensor is located behind starter motor (remove starter)and cam sensor fits into manifold area
 Jeep 2010 on Fuel pump wont switch off or battery keeps going flat Power Module faulty,this is plastic box that has relays and fuses,located in engine bay-is faulty do some tests on inputs and outputs-Common fault-genuine price around $3000.00 BEWARE

Kia Sportage

Cutting out

Wiring loom loose at back of head melting on EGR pipes

Kia Sportage

No injector pulse

Power to smart lock, check tail light fuse.

 Lexus IS350  Cam Timing/noise  Variable Valve timing actuator-Beware- bolts break that holds housing and sprocket/will destroy engine
Mazda Tribute V6 Misfire codes coils,if code still there after fitting coils,repair coil drivers in ECU (we do heaps) if code and misfire still there do wiggle test at plug to ECU as wires get brittle near ECU

Mazda V6/ Telstar 2.5

No spark

Replace dizzy (common fault)

Also check fault codes- If crank sensor code, beware as some have separate crank sensor on front of engine (replace)

Mazda V6/ Telstar 2.5

Surging / Stalling

Check codes O2 sensors replace both (common fault)

 Mazda BT50 BEWARE -oil change You must drain and refill within 5 minutes,otherwise oil pump will drain AND you will have no oil pressure. $3000 to repair-BEWARE
 Mazda3/6 Diesel DPF- diesel part filter code Do with scan tool to clean,if code wont erase,pull off filter and clean out with gurney,refit and do again
 Mercedes 2006 0n V6 check light on-codes cam sensor Cams out of range,usaully cam timing out or worn cam belt/chain-major job

Mitsh all models 1996/on

Wont start, Immobiliser code. Has spark but no injector pulse.

Usually worn key. Immoboliser signal missing to ECU. Try spare key (common fault)

Magna TE/TF V6 with dizzy Crank angle sensor code BEWARE-crank sensor is not in dizzy(cam sensor is).crank sensor is at behind timing belt at crankshaft

Mitsh 1996 on 4cyl/ V6

 

Runs rough

Crank sensor code (not always)

Timing belt out 1 tooth or crank sensor oil soaked or C.A.S disc plate loose behind crank timing belt pulley (common fault)

Mitsh most models with immobiliser

no inj pulse but has spark

Wrong or worn key,immobiliser will lock and shut system down if constant no start-to reset switch ign on for 60 minutes then switch ign OFF for 5 minutes ,car should now restart

Mitsh Lancer CE

1996-2003

Speedo failure

Incorrect spark plugs!

Must use resistor plugs or will damage microprocessor on speedo circuit board.

Lancer/io pajero/ 1.8/2.0

no start after fitting engine or head

coil plug and crank sensor connector fitted on incorrectly (wrong way round) ,will fry computer

Lancer CE

Misfiring on 1 cyl,after repairs

Code 44

Because cam timing has been adjusted,sometimes code 44 will come up,to reset disconnect battery for 3 minutes,will fix problem

Mitsh Magna TE V6

Auto limp mode, Bangs into reverse gear

Check reverse light, if the fuse is blown it locks into limp mode

 Mitsh,models with crank sensor behind timing belt  misfire-no fault codes  check copper plate for crank sensor not loose or bent

Mitsh Magna TR / TS

Bad idle

I.S.C motor, computer or airflow meter.

TR / TS

Auto trans stuck in 3rd gear (limp mode)

Trans ECU faulty or TPS connection corroded

TR/TS

T.P.S Code stuck

Check green wire on end ECU plug. (Pulls out when pulling on ECU plug to change ECU).

TR/TS 4cyl

Cuts out, bad connection to dizzy. Do wiggle test.

Replace plug & dizzy. Check plug to TPS.

Common fault.

TS 4 &V6

No spark, has injector pulse or no earth to start relay

Late TS has immobiliser fitted behind ECU plate stops ignitor. To rectify rewire ignitor wire direct to ECU

Magna TE- TH V6

No idle after repairs or battery change or S light
 AWD light stuck on

This a common fault,as ECU loses memory,to reset- ign on,press mode button until beep is heard,display screen will show engine capacity,if not correct eng shown use trip computer up & down to set eng size,then press Mode button until beep is heard!this should reset idle

Magna/Pajero V6

Runs rough, surging, intermittent,No codes

O2 sensor faulty,disconnect to verify

 Pajero 3.5 Misfire after changing coils
 Beware as ignition module behind throttle body,has dropped one coil.   module-has 3 pin and 6 pin plug,to test swap coils to verify same cyl misfire

Mitsh Triton/ L300 2.4 with dizzy on cam cover

 

Surging,

No power

Worn dizzy drive plate on front of cam, only wears 3mm but changes timing 20° both ways on cruise.

 Mitsh 380  02 codes check all 02 sensors are working,this is a common fault and hard to fix-this sensors have a pulsing 12 volt signal out of ECU,if constat 12 volts or none,you can join wire near ECU to working 02
also if lean codes ,listen for purge control valve clicking,if so replace valve 

Nissan Bluebird

Runs rough

Cutting out

Oil in dizzy.

Replace dizzy

Nissan Exa 1.6-1.8 300Z /RB20/25

Misfire on 1 cylinder

Faulty ignition module, Replace.

Nissan Maxima V6 early model

Runs rough, cuts out surging

Water leaking onto ECU wiring in front of centre console (common fault)

Nissan Maxima A33-A34

Bad idle/ Stalling.

Idle motor fails due to water leaking into ISC  & then burns out idle circuit in ECU.

 Replace idle motor & repair ECU if burnt board.

Maxima A32/33/34 No start ,ECU smells burnt ECU board burnt due to electronic engine mount collapse, shorting out wiring,new ECU + engine mount,common fault

Nissan Patrol Turbo Diesel EFI

Wont rev

Airflow meter.

Disconnect to verify

Nissan Pathfinder/ Navara 3LT V6

Stalls after warm up or running lean or surging no fault codes

This is a common fault it is a faulty oxygen sensor switching incorrectly when warming up. Disconnect O2 sensor to verify.

Navara ZD30 Diesel Surging Air flow meter or inlet hose from turbo split
 Navara D22 Crank sensor code no start No start after fitting crank sensor-Faulty starter motor
(brushes worn out) bad signal to ecu from crank 
 Navara D40 2.5  stalling/no power  1st gear switch faulty
Late Navara V6 Misfire on 1 bank

Check voltage to coil packs (both banks) Must have battery ,if 6 or 8 volts it has a faulty ignition relay .there is a bank of relays located LH guard area.switch relays around to find faulty relay

NOTE-this is a common fault as Nissan recalled these vechiles to solve this problem

Nissan N16

No start or cutting out

This is a common fault,faulty cam or crank sensor-replace both as linked to same circuit in ECU (usaually no fault code)

Nissan Pulsar N15/ N16

Bad idle/ Stalling.

Idle motor fails due to water leaking into ISC  & then burns out idle circuit in ECU.

 Replace idle motor & repair ECU if burnt board.

Nissan N16

Crank or Cam sensor code stuck, stalling

Timing chain tensioner worn, or chain stretched. To check line up dots on cams, then measure tensioner piston protrusion, if it is over 10mm the chain is stretched!

Nissan N16 no power could be air flow sensor,blocked cat,sometimes blown stop lights or fuse will make car go into limp mode
 N16  no start after fitting new idle motor,or ECU  faulty parts have blown ign fuse

Nissan N16 with VVT

Bad idle when hot

Check inlet cam VVT sensor, wont retard inlet cam when returns to idle. Change engine oil or replace VVT switch (No code)

Nissan Pulsar N14/15/16

Hard to start cold

No signal from starter motor to ECU wont advance or richen, must see 8volts plus at starter pin in ECU. Check start fuse in fuse panel (common fault)

Nissan X-Trail

Bad Idle after repairs or service

BEWARE-This is a common fault!do not clean throttle body,or disconnect t/body ,you must do relearn  procedure or replace t/body/ if still no better it has to go to nissan dealer for program upgrade or use  scan tool,we sell heaps of throttle bodys-beware!
X Trail Crank sensor or cam codes Replace both sensors,also if head or major work has been done and this code is stuck check you havent fiited power steer plug to crank sensor ,this is a common fault
 Xtrail If cam/crank codes still stuck on Timing chain has stretched-check protrusion on tensioner-major job- beware
 Corolla Avensis  Auto shift problems/shuddering on take off  Faulty ECU (we have in stock)-if left to long will burn out transmisson

Toyotaall models

2006 on

Lost or damaged key

 

You have to replace key, barrel kit & computer costs $1500 to $2300.

ToyotaCamry SVD10 4cyl

Cuts out

Hard to start

Plug in dizzy faulty to rectify replace dizzy.if map sensor code ,it will be a faulty computer

ToyotaCamry V6 96-01

Surging

Stalling

EGR Valve incorrectly switching, replace EGR sensor (common fault)

Camry /Corolla /Rav4(coil over plugs) 4cyl

Wont start or runs rough

Short in one coil sends voltage down earth wires to ECU. Disconnect 1 coil at a time to find faulty coil.

Rav 4 2003 on

Auto shift problems shuddering

ECU faulty (common fault) If left too long burns out end clutch in trans. we can supply programed ECU

 Rav 4/Tarago 2azfe 2.4
Throttle body codes after fitting t/body
 Check fuse 10amp pass side eng bay

Echo with variable cam timing

No power

Wrong or old engine oil causing VVS sensor not to move. Use oil flush & correct grade oil.If still no power the airflow meter is faulty(usually no fault code)

Common fault

 Toyota-most models Reset elec throttle bodyturn ign on and you will notice it oscillate for a while-let it settle-in neutral,rev the car to about 2000 rpm for about 5 minutes.then let car idle for 2 minutes.turn car off and restart it,then road test
 Hi-ace/hi lux Diesel fuel filter light stuck on To reset-ign off-disconnect top plug at filter-turn ign on-wait 5 seconds then refit plug to filter

Saab 84-96

No fuel pump supply

Check voltage to pump, if none ECU faulty, not switching relay (Common fault).

Saab 84-96

Surging, lack of power.

Airflow meter! Check fuel pressure & flow.

SAAB late model

misfire

One piece coil pack ass faulty-replace (common fault)

Subaru most models Check light on but when you check code -no trouble code,hard to start and cuts out at idle This is a COMMON fault.tell customer to bring car back when check light IS on,do not switch engine off,check code while motor is running,will bring up cam sensor out of phase,replace cam and crank sensor

Subaru 98 on

Wont start.

No injector pulse

Worn key (common fault)

Liberty Shudder and noise in gearbox when turning Put fuse into fuse holder under bonnet for RWD,this disengages RWD or repair gearbox

Subaru late

In limp mode,will change gears but no power,no cruise control

Check that brake lights are working. If brake light fuse blown will cause the vehicle to go into limp mode.

Liberty and others Fuel pump fuse blowing Disconnect pump and if still blowing fuse,check 02 wiring loom grounds out on exhaust.same fuse as fuel pump

Subaru late

Wont rev

Air flow meter faulty, disconnect to verify.

Subaru late

Misfire

No codes

Faulty coil pack & change leads

(common fault)

Subaru 2004 on check and cruise light on dash,cruise not working fault code 02 sensor-when you replace front 02 sensor,cruise control will work again and both dash lights will be off?
Suzuki,most models Cuts out and hard to start sometimes,check light comes on but no fault codes Check codes when check light comes on WITH motor running,will bring up cam sensor out of phase,replace,NOTE this is a common fault,wont register code when you switch engine off
 Suzuki 2000 on
V6
Grand Vitara
 misfiring,hard to start Check computer under dash,water leak at air con hose,leaks into ECU-cant repair most of them $2500 for new unit,we can reprograme s/hand unit
Note-common fault

Volvo 84-96

No fuel pump supply

Check voltage to pump, if none ECU faulty, not switching relay (Common fault).

Volvo 84-96

Surging, lack of power.   

Airflow meter! Check fuel pressure & flow.

VW / Seat

Cutting out

No spark

Faulty coil. Test signal out of dizzy, replace pickup in dizzy & coil.

VW- Seat 1998 on

Bad idle, stalling

Electronic throttle body or vacuum leak.

VW/ Seat 1996 on

With coil over

Misfire

Faulty Coils ( Common fault)

VW Transporter 2.0/2.5LT   

Cutting out, No start sometimes

Faulty EFI relay number 30 under the dash, it cuts power to pump or coil. Replace it & wiring loom under the intake manifold if corroded & bare wires touching.

Common fault

VW Transporter 2.0/2.5LT   

Hard to start cold,runs rich   

If previous tests done. I have found that coolant temp switch is faulty, check voltage

 VW Amarok NO start after changing fuel filter BEWARE-use only genunie fuel filter-YOU have to use scan tool to prime pump in tank before start up,other wise you will need to fill filter (big job) and pressure fuel tank to prime engine-can take up to 2 hours -BEWARE

<< Previous page